aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTerry Chia <terrycwk1994@gmail.com>2015-09-30 19:13:14 +0800
committerTerry Chia <terrycwk1994@gmail.com>2015-09-30 19:13:14 +0800
commit36a787ff216dff16e49c3cbc8895515588697337 (patch)
treece9d712232c497c00c2131d60b7e6d4018528717
parent3d7f8d1d6cf268f5c0c482c8d1cce7ec773a7030 (diff)
downloadcryptography-36a787ff216dff16e49c3cbc8895515588697337.tar.gz
cryptography-36a787ff216dff16e49c3cbc8895515588697337.tar.bz2
cryptography-36a787ff216dff16e49c3cbc8895515588697337.zip
Address comments.
-rw-r--r--setup.py6
-rw-r--r--tests/test_with_hypothesis.py3
2 files changed, 4 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index d00f9fe8..167b62e0 100644
--- a/setup.py
+++ b/setup.py
@@ -60,12 +60,10 @@ test_requirements = [
"pytest<2.8",
"pretend",
"iso8601",
+ "hypothesis",
+ "hypothesis-pytest",
]
-if sys.version_info[:2] != (2, 6):
- test_requirements.append("hypothesis")
- test_requirements.append("hypothesis-pytest")
-
# If there's no vectors locally that probably means we are in a tarball and
# need to go and get the matching vectors package from PyPi
if not os.path.exists(os.path.join(base_dir, "vectors/setup.py")):
diff --git a/tests/test_with_hypothesis.py b/tests/test_with_hypothesis.py
index 31dfa04c..5a181216 100644
--- a/tests/test_with_hypothesis.py
+++ b/tests/test_with_hypothesis.py
@@ -1,3 +1,4 @@
+from hypothesis import given
from hypothesis.strategies import binary
import pytest
@@ -8,7 +9,7 @@ from cryptography.fernet import Fernet
hypothesis = pytest.importorskip("hypothesis")
-@hypothesis.given(binary())
+@given(binary())
def test_fernet(data):
f = Fernet(Fernet.generate_key())
ct = f.encrypt(data)