aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Stapleton <alexs@prol.etari.at>2014-03-24 23:05:53 +0000
committerAlex Stapleton <alexs@prol.etari.at>2014-03-24 23:05:53 +0000
commit3888a84c2b7fc45adf3fa665880d554c1766165e (patch)
tree3ced92983980b7a034401fba43f6b7084fb359f0
parenta39a319b096b1b2b1775ae1a91117c19422a6c81 (diff)
downloadcryptography-3888a84c2b7fc45adf3fa665880d554c1766165e.tar.gz
cryptography-3888a84c2b7fc45adf3fa665880d554c1766165e.tar.bz2
cryptography-3888a84c2b7fc45adf3fa665880d554c1766165e.zip
Fix bug in release task and style fixes
tasks.py was building tarballs/sdists that didn't actually have vectors in because of setup.pys reliance on the cwd.
-rw-r--r--tasks.py4
-rw-r--r--tox.ini3
-rw-r--r--vectors/setup.py1
3 files changed, 4 insertions, 4 deletions
diff --git a/tasks.py b/tasks.py
index c124560e..c205ac88 100644
--- a/tasks.py
+++ b/tasks.py
@@ -84,11 +84,11 @@ def release(version):
invoke.run("git push --tags")
invoke.run("python setup.py sdist")
- invoke.run("python vectors/setup.py sdist")
+ invoke.run("cd vectors/ && python setup.py sdist bdist_wheel")
invoke.run(
"twine upload -s dist/cryptography-{0}* "
- "dist/cryptography_vectors-{0}*".format(version)
+ "vectors/dist/cryptography_vectors-{0}*".format(version)
)
token = getpass.getpass("Input the Jenkins token: ")
diff --git a/tox.ini b/tox.ini
index eaebd5c6..eb8e2750 100644
--- a/tox.ini
+++ b/tox.ini
@@ -7,8 +7,8 @@ deps =
iso8601
pretend
pytest
+ ./vectors
commands =
- pip install -e vectors
coverage run --source=cryptography/,tests/ -m pytest --capture=no --strict {posargs}
coverage report -m
@@ -36,7 +36,6 @@ commands =
# coverage.py on pypy.
[testenv:pypy]
commands =
- pip install -e vectors
py.test --capture=no --strict {posargs}
[testenv:pep8]
diff --git a/vectors/setup.py b/vectors/setup.py
index 13b27c7d..ce01e132 100644
--- a/vectors/setup.py
+++ b/vectors/setup.py
@@ -14,6 +14,7 @@
from __future__ import absolute_import, division, print_function
import os
+
from setuptools import setup, find_packages