diff options
author | Paul Kehrer <paul.l.kehrer@gmail.com> | 2015-06-08 00:05:53 -0500 |
---|---|---|
committer | Paul Kehrer <paul.l.kehrer@gmail.com> | 2015-06-08 00:05:53 -0500 |
commit | 4c287d704ff716769348019266c26814dfb90b37 (patch) | |
tree | 59fe7d4ef7e1351ae9bf95c442ae93455f004809 | |
parent | 4ff26abc0f48db53fcc0b321162a7129fd7fbdc6 (diff) | |
download | cryptography-4c287d704ff716769348019266c26814dfb90b37.tar.gz cryptography-4c287d704ff716769348019266c26814dfb90b37.tar.bz2 cryptography-4c287d704ff716769348019266c26814dfb90b37.zip |
setup requires can be cffi only now
-rw-r--r-- | setup.py | 4 |
1 files changed, 3 insertions, 1 deletions
@@ -37,6 +37,7 @@ requirements = [ "six>=1.4.1", "setuptools" ] +setup_requirements = [] if sys.version_info < (3, 4): requirements.append("enum34") @@ -46,6 +47,7 @@ if sys.version_info < (3, 3): if platform.python_implementation() != "PyPy": requirements.append("cffi>=1.1.0") + setup_requirements.append("cffi>=1.1.0") # If you add a new dep here you probably need to add it in the tox.ini as well test_requirements = [ @@ -203,7 +205,7 @@ def keywords_with_side_effects(argv): cffi_modules.append("src/_cffi_src/build_commoncrypto.py:ffi") return { - "setup_requires": requirements, + "setup_requires": setup_requirements, "cmdclass": { "test": PyTest, }, |