aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Gaynor <alex.gaynor@gmail.com>2015-04-18 21:53:20 -0400
committerAlex Gaynor <alex.gaynor@gmail.com>2015-04-18 21:53:20 -0400
commit7476b13b4953fd750d0484b0227e5de7b6cfeea8 (patch)
tree723f3c3c3b62be131ed038f0133304a8591abb7a
parent702ef6ac75c9e84e221e6696d324bada8076ecb4 (diff)
parent0958641277aee556a047ee9b3cccf6d42f11e09c (diff)
downloadcryptography-7476b13b4953fd750d0484b0227e5de7b6cfeea8.tar.gz
cryptography-7476b13b4953fd750d0484b0227e5de7b6cfeea8.tar.bz2
cryptography-7476b13b4953fd750d0484b0227e5de7b6cfeea8.zip
Merge pull request #1846 from reaperhulk/drop-python-32
Drop support for Python 3.2
-rw-r--r--.travis.yml16
-rwxr-xr-x.travis/install.sh5
-rw-r--r--CHANGELOG.rst2
-rw-r--r--README.rst2
-rw-r--r--docs/development/getting-started.rst1
-rw-r--r--docs/installation.rst2
-rw-r--r--setup.py1
-rw-r--r--tox.ini2
8 files changed, 5 insertions, 26 deletions
diff --git a/.travis.yml b/.travis.yml
index 251eb079..71efd8ff 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -9,8 +9,6 @@ matrix:
env: TOXENV=py26
- python: 2.7
env: TOXENV=py27
- - python: 3.2
- env: TOXENV=py32
- python: 3.3
env: TOXENV=py33
- python: 3.4
@@ -33,14 +31,6 @@ matrix:
- lucid
packages:
- libssl-dev/lucid
- - python: 3.2
- env: TOXENV=py32 OPENSSL=0.9.8
- addons:
- apt:
- sources:
- - lucid
- packages:
- - libssl-dev/lucid
- python: 3.3
env: TOXENV=py33 OPENSSL=0.9.8
addons:
@@ -83,9 +73,6 @@ matrix:
env: TOXENV=py27
- language: generic
os: osx
- env: TOXENV=py32
- - language: generic
- os: osx
env: TOXENV=py33
- language: generic
os: osx
@@ -104,9 +91,6 @@ matrix:
env: TOXENV=py27 OPENSSL=0.9.8
- language: generic
os: osx
- env: TOXENV=py32 OPENSSL=0.9.8
- - language: generic
- os: osx
env: TOXENV=py33 OPENSSL=0.9.8
- language: generic
os: osx
diff --git a/.travis/install.sh b/.travis/install.sh
index f7f3d502..9e14a92d 100755
--- a/.travis/install.sh
+++ b/.travis/install.sh
@@ -23,11 +23,6 @@ if [[ "$(uname -s)" == 'Darwin' ]]; then
curl -O https://bootstrap.pypa.io/get-pip.py
python get-pip.py --user
;;
- py32)
- brew upgrade pyenv
- pyenv install 3.2.6
- pyenv global 3.2.6
- ;;
py33)
brew upgrade pyenv
pyenv install 3.3.6
diff --git a/CHANGELOG.rst b/CHANGELOG.rst
index 69eea525..c91b7c75 100644
--- a/CHANGELOG.rst
+++ b/CHANGELOG.rst
@@ -6,6 +6,8 @@ Changelog
.. note:: This version is not yet released and is under active development.
+* Removed support for Python 3.2. This version of Python is rarely used
+ and caused support headaches. Users affected by this should upgrade to 3.3+.
* Deprecated support for Python 2.6. At the time there is no time table for
actually dropping support, however we strongly encourage all users to upgrade
their Python, as Python 2.6 no longer receives support from the Python core
diff --git a/README.rst b/README.rst
index 1277505a..4f5c646f 100644
--- a/README.rst
+++ b/README.rst
@@ -18,7 +18,7 @@ Cryptography
``cryptography`` is a package which provides cryptographic recipes and
primitives to Python developers. Our goal is for it to be your "cryptographic
-standard library". It supports Python 2.6-2.7, Python 3.2+, and PyPy.
+standard library". It supports Python 2.6-2.7, Python 3.3+, and PyPy.
``cryptography`` includes both high level recipes, and low level interfaces to
common cryptographic algorithms such as symmetric ciphers, message digests and
diff --git a/docs/development/getting-started.rst b/docs/development/getting-started.rst
index f5d6c190..b3474002 100644
--- a/docs/development/getting-started.rst
+++ b/docs/development/getting-started.rst
@@ -44,7 +44,6 @@ each supported Python version and run the tests. For example:
ERROR: py26: InterpreterNotFound: python2.6
py27: commands succeeded
ERROR: pypy: InterpreterNotFound: pypy
- ERROR: py32: InterpreterNotFound: python3.2
py33: commands succeeded
docs: commands succeeded
pep8: commands succeeded
diff --git a/docs/installation.rst b/docs/installation.rst
index c061903e..1c25ff78 100644
--- a/docs/installation.rst
+++ b/docs/installation.rst
@@ -10,7 +10,7 @@ You can install ``cryptography`` with ``pip``:
Supported platforms
-------------------
-Currently we test ``cryptography`` on Python 2.6, 2.7, 3.2, 3.3, 3.4 and PyPy
+Currently we test ``cryptography`` on Python 2.6, 2.7, 3.3, 3.4 and PyPy
on these operating systems.
* x86-64 CentOS 7.x, 6.4 and CentOS 5.x
diff --git a/setup.py b/setup.py
index f66977ee..6376a1f5 100644
--- a/setup.py
+++ b/setup.py
@@ -318,7 +318,6 @@ setup(
"Programming Language :: Python :: 2.6",
"Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.2",
"Programming Language :: Python :: 3.3",
"Programming Language :: Python :: 3.4",
"Programming Language :: Python :: Implementation :: CPython",
diff --git a/tox.ini b/tox.ini
index dc8811af..759345f5 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py26,py27,pypy,py32,py33,py34,docs,pep8,py3pep8
+envlist = py26,py27,pypy,py33,py34,docs,pep8,py3pep8
[testenv]
# If you add a new dep here you probably need to add it in setup.py as well