diff options
author | Alex Gaynor <alex.gaynor@gmail.com> | 2014-01-03 07:34:43 -0800 |
---|---|---|
committer | Alex Gaynor <alex.gaynor@gmail.com> | 2014-01-03 07:34:43 -0800 |
commit | 7630d6c50b3112eae69de606760cfb3e3b070c26 (patch) | |
tree | b39259dd1068e05d8ee85d94467ab898e21de2fd | |
parent | f51f2c1c5f24f627cfe57c2ea6d821c87f7a6c20 (diff) | |
download | cryptography-7630d6c50b3112eae69de606760cfb3e3b070c26.tar.gz cryptography-7630d6c50b3112eae69de606760cfb3e3b070c26.tar.bz2 cryptography-7630d6c50b3112eae69de606760cfb3e3b070c26.zip |
Also use an absolute path for the about file
-rw-r--r-- | setup.py | 8 |
1 files changed, 5 insertions, 3 deletions
@@ -15,9 +15,11 @@ import os from setuptools import setup, find_packages +base_dir = os.path.dirname(__file__) + about = {} -with open("cryptography/__about__.py") as fp: - exec(fp.read(), about) +with open(os.path.join(base_dir, "cryptography", "__about__.py")) as f: + exec(f.read(), about) CFFI_DEPENDENCY = "cffi>=0.6" @@ -32,7 +34,7 @@ setup_requires = [ CFFI_DEPENDENCY, ] -with open(os.path.join(os.path.dirname(__file__), "README.rst")) as f: +with open(os.path.join(base_dir, "README.rst")) as f: long_description = f.read() |