diff options
author | Alex Gaynor <alex.gaynor@gmail.com> | 2015-02-20 07:58:39 -0800 |
---|---|---|
committer | Alex Gaynor <alex.gaynor@gmail.com> | 2015-02-20 07:58:39 -0800 |
commit | 8a58e6997b8b4abfed11a8a23b539e261fde1a28 (patch) | |
tree | 2c965d42fd14130a6ef4c83ce02a30251311da33 | |
parent | 8be38b39270d4545bb303eb08fa5e84940de04a2 (diff) | |
download | cryptography-8a58e6997b8b4abfed11a8a23b539e261fde1a28.tar.gz cryptography-8a58e6997b8b4abfed11a8a23b539e261fde1a28.tar.bz2 cryptography-8a58e6997b8b4abfed11a8a23b539e261fde1a28.zip |
Tell py.test to only run the tests from the local tests dir.
Right now if you have a virtualenv or something in the same directory it will recurse into it to run tests.
-rw-r--r-- | setup.py | 3 |
1 files changed, 2 insertions, 1 deletions
@@ -135,7 +135,8 @@ class PyTest(test): def run_tests(self): # Import here because in module scope the eggs are not loaded. import pytest - errno = pytest.main(self.test_args) + test_args = [os.path.join(base_dir, "tests")] + errno = pytest.main(test_args) sys.exit(errno) |