diff options
author | Alex Gaynor <alex.gaynor@gmail.com> | 2014-01-02 13:12:59 -0800 |
---|---|---|
committer | Alex Gaynor <alex.gaynor@gmail.com> | 2014-01-02 13:12:59 -0800 |
commit | 91f119e75865e72d66e8c8b4f24164988e5b8d20 (patch) | |
tree | 11b51f66a02a748086fc1ea82a171631da1c9d83 | |
parent | 9a00f0539d5ab9b03b84625791663f11d7bed75c (diff) | |
download | cryptography-91f119e75865e72d66e8c8b4f24164988e5b8d20.tar.gz cryptography-91f119e75865e72d66e8c8b4f24164988e5b8d20.tar.bz2 cryptography-91f119e75865e72d66e8c8b4f24164988e5b8d20.zip |
six is now required at build time
-rw-r--r-- | setup.py | 10 |
1 files changed, 3 insertions, 7 deletions
@@ -23,15 +23,11 @@ with open("cryptography/__about__.py") as fp: CFFI_DEPENDENCY = "cffi>=0.6" SIX_DEPENDENCY = "six>=1.4.1" -install_requires = [ +requirements = [ CFFI_DEPENDENCY, SIX_DEPENDENCY ] -setup_requires = [ - CFFI_DEPENDENCY, -] - class cffi_build(build): def finalize_options(self): @@ -81,8 +77,8 @@ setup( packages=find_packages(exclude=["tests", "tests.*"]), - install_requires=install_requires, - setup_requires=setup_requires, + install_requires=requirements, + setup_requires=requirements, # for cffi zip_safe=False, |