aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Kehrer <paul.l.kehrer@gmail.com>2014-02-19 18:26:46 -0600
committerPaul Kehrer <paul.l.kehrer@gmail.com>2014-02-19 18:26:46 -0600
commita1caeff390f0500c90e7b7ff1a9050778c714c67 (patch)
tree2a0fe755720040d5ba82cdea7890cde2fdac8903
parent176ae10d9aea37ddb3622573bc2e611cd73889af (diff)
parentc9e4c6af4ce77c703c32b4c611075987960f7b64 (diff)
downloadcryptography-a1caeff390f0500c90e7b7ff1a9050778c714c67.tar.gz
cryptography-a1caeff390f0500c90e7b7ff1a9050778c714c67.tar.bz2
cryptography-a1caeff390f0500c90e7b7ff1a9050778c714c67.zip
Merge pull request #643 from alex/windows-wheels
Refs #506 -- Trigger creation of wheels when doing a release
-rw-r--r--tasks.py17
1 files changed, 17 insertions, 0 deletions
diff --git a/tasks.py b/tasks.py
index f72f43ba..5fa86986 100644
--- a/tasks.py
+++ b/tasks.py
@@ -12,8 +12,15 @@
# limitations under the License.
from __future__ import absolute_import, division, print_function
+import getpass
+
import invoke
+import requests
+
+
+JENKINS_ROOT = "http://jenkins.cryptography.io"
+
@invoke.task
def release(version):
@@ -25,3 +32,13 @@ def release(version):
invoke.run("python setup.py sdist")
invoke.run("twine upload -s dist/cryptography-{0}*".format(version))
+
+ token = getpass.getpass("Input the Jenkins token")
+ response = requests.post(
+ "{0}/job/cryptography-wheel-builder/build".format(JENKINS_ROOT),
+ params={
+ "token": token,
+ "cause": "Building wheels for {0}".format(version)
+ }
+ )
+ response.raise_for_status()