diff options
author | Peter Odding <peter@peterodding.com> | 2014-07-13 04:17:20 +0200 |
---|---|---|
committer | Paul Kehrer <paul.l.kehrer@gmail.com> | 2014-09-29 11:44:32 -0500 |
commit | c9861f9bd496089faf29f2e0022727fcc17e413b (patch) | |
tree | 6afbbb1c933f5940ece54c5907f88b9a1be0af70 | |
parent | e9144566b6fe539256487687dfa5e863f7bdee96 (diff) | |
download | cryptography-c9861f9bd496089faf29f2e0022727fcc17e413b.tar.gz cryptography-c9861f9bd496089faf29f2e0022727fcc17e413b.tar.bz2 cryptography-c9861f9bd496089faf29f2e0022727fcc17e413b.zip |
Simplify dummy commands (fix inheritance, remove finalize_options())
-rw-r--r-- | setup.py | 15 |
1 files changed, 3 insertions, 12 deletions
@@ -224,44 +224,35 @@ setup_requires_error = ("Requested setup command that needs 'setup_requires' " "free command or option.") -class DummyCFFIBuild(CFFIBuild): +class DummyCFFIBuild(build): """ This class makes it very obvious when ``keywords_with_side_effects()`` has incorrectly interpreted the command line arguments to ``setup.py build`` as one of the 'side effect free' commands or options. """ - def finalize_options(self): - build.finalize_options(self) - def run(self): raise RuntimeError(setup_requires_error) -class DummyCFFIInstall(CFFIInstall): +class DummyCFFIInstall(install): """ This class makes it very obvious when ``keywords_with_side_effects()`` has incorrectly interpreted the command line arguments to ``setup.py install`` as one of the 'side effect free' commands or options. """ - def finalize_options(self): - install.finalize_options(self) - def run(self): raise RuntimeError(setup_requires_error) -class DummyPyTest(PyTest): +class DummyPyTest(test): """ This class makes it very obvious when ``keywords_with_side_effects()`` has incorrectly interpreted the command line arguments to ``setup.py test`` as one of the 'side effect free' commands or options. """ - def finalize_options(self): - test.finalize_options(self) - def run_tests(self): raise RuntimeError(setup_requires_error) |