aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Gaynor <alex.gaynor@gmail.com>2014-07-11 10:18:24 -0700
committerAlex Gaynor <alex.gaynor@gmail.com>2014-07-11 10:18:24 -0700
commitd9f9b75ad6514bb184dd6803d57d7f3f805ffb96 (patch)
tree68ca2a2f3a1cf8954b2c372a34a8157c38f694e5
parentcb70d20e55330ab1027fa74674b03f7d593b6bb7 (diff)
downloadcryptography-d9f9b75ad6514bb184dd6803d57d7f3f805ffb96.tar.gz
cryptography-d9f9b75ad6514bb184dd6803d57d7f3f805ffb96.tar.bz2
cryptography-d9f9b75ad6514bb184dd6803d57d7f3f805ffb96.zip
Check for errors when invoking the vectors setup.py
-rw-r--r--setup.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 4dd9e629..f73394ee 100644
--- a/setup.py
+++ b/setup.py
@@ -110,8 +110,9 @@ class PyTest(test):
# This means there's a vectors/ folder with the package in here.
# cd into it, install the vectors package and then refresh sys.path
if VECTORS_DEPENDENCY not in test_requirements:
- subprocess.Popen([sys.executable, "setup.py", "install"],
- cwd="vectors").communicate()
+ subprocess.check_call(
+ [sys.executable, "setup.py", "install"], cwd="vectors"
+ )
pkg_resources.get_distribution("cryptography_vectors").activate()
def run_tests(self):