diff options
author | Paul Kehrer <paul.l.kehrer@gmail.com> | 2016-02-19 12:38:20 -0600 |
---|---|---|
committer | Paul Kehrer <paul.l.kehrer@gmail.com> | 2016-02-19 12:38:20 -0600 |
commit | eefc01ff04be97a7430133536ed5fbad893717fa (patch) | |
tree | 8b8b844bbbf61c5b2dcc6b188514034af2c85471 | |
parent | f068325e25dbacd1c12e6b684539320f1ce18c4c (diff) | |
parent | de3aa05c45c5144422c9139e385630b1d928b73f (diff) | |
download | cryptography-eefc01ff04be97a7430133536ed5fbad893717fa.tar.gz cryptography-eefc01ff04be97a7430133536ed5fbad893717fa.tar.bz2 cryptography-eefc01ff04be97a7430133536ed5fbad893717fa.zip |
Merge pull request #2726 from alex/hypothesis-2.6
Don't try to use hypothesis on Python 2.6, upstream dropped support
-rw-r--r-- | setup.py | 4 | ||||
-rw-r--r-- | tests/hypothesis/__init__.py | 4 |
2 files changed, 7 insertions, 1 deletions
@@ -61,9 +61,11 @@ test_requirements = [ "pytest", "pretend", "iso8601", - "hypothesis>=1.11.4", "pyasn1_modules", ] +if sys.version_info[:2] > (2, 6): + test_requirements.append("hypothesis>=1.11.4") + # If there's no vectors locally that probably means we are in a tarball and # need to go and get the matching vectors package from PyPi diff --git a/tests/hypothesis/__init__.py b/tests/hypothesis/__init__.py index 4b540884..0b344066 100644 --- a/tests/hypothesis/__init__.py +++ b/tests/hypothesis/__init__.py @@ -3,3 +3,7 @@ # for complete details. from __future__ import absolute_import, division, print_function + +import pytest +# hypothesis no longer supports Python 2.6 so we simply skip it there +pytest.importorskip("hypothesis") |