aboutsummaryrefslogtreecommitdiffstats
path: root/Jenkinsfile
diff options
context:
space:
mode:
authorAlex Gaynor <alex.gaynor@gmail.com>2019-05-07 15:52:49 -0400
committerPaul Kehrer <paul.l.kehrer@gmail.com>2019-05-07 15:52:49 -0400
commitab115a9d1953f4e71be818b614beba96fd96df22 (patch)
tree95029c3499cc20e2c08ea42fddb246e715d21720 /Jenkinsfile
parenta7e09d8b4f7c25fec4e270d9549dff521648ca3c (diff)
downloadcryptography-ab115a9d1953f4e71be818b614beba96fd96df22.tar.gz
cryptography-ab115a9d1953f4e71be818b614beba96fd96df22.tar.bz2
cryptography-ab115a9d1953f4e71be818b614beba96fd96df22.zip
Drop setup.py test support. (#4879)
* Drop setup.py test support. It's fragile and relies on eggs. While our downstream redistributors don't love this (sorry!), it seems like the right tradeoff. * Remove unused * Added a changelog entry * typo * line length
Diffstat (limited to 'Jenkinsfile')
-rw-r--r--Jenkinsfile23
1 files changed, 0 insertions, 23 deletions
diff --git a/Jenkinsfile b/Jenkinsfile
index 14a1ed7f..e4475741 100644
--- a/Jenkinsfile
+++ b/Jenkinsfile
@@ -221,27 +221,4 @@ for (config in configs) {
}
}
-/* Add the python setup.py test builder */
-builders["setup.py-test"] = {
- node("docker") {
- stage("python setup.py test") {
- docker.image("pyca/cryptography-runner-ubuntu-rolling").inside {
- try {
- checkout_git("docker")
- sh """#!/usr/bin/env bash
- set -xe
- cd cryptography
- virtualenv .venv
- source .venv/bin/activate
- python setup.py test
- """
- } finally {
- deleteDir()
- }
-
- }
- }
- }
-}
-
parallel builders