aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAlex Gaynor <alex.gaynor@gmail.com>2016-02-19 17:12:21 -0500
committerAlex Gaynor <alex.gaynor@gmail.com>2016-02-19 17:12:21 -0500
commit1d8ead8364f164d505bf49e05441d1430fc80039 (patch)
tree286b39f8a58c32349d3f44d4a52bfdf5fdc51c59 /setup.py
parentf7721aaaa14f789e911a61e5e946d618521920a9 (diff)
parenteefc01ff04be97a7430133536ed5fbad893717fa (diff)
downloadcryptography-1d8ead8364f164d505bf49e05441d1430fc80039.tar.gz
cryptography-1d8ead8364f164d505bf49e05441d1430fc80039.tar.bz2
cryptography-1d8ead8364f164d505bf49e05441d1430fc80039.zip
Merge branch 'master' into security-docs
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 72675295..88dfd7de 100644
--- a/setup.py
+++ b/setup.py
@@ -61,9 +61,11 @@ test_requirements = [
"pytest",
"pretend",
"iso8601",
- "hypothesis>=1.11.4",
"pyasn1_modules",
]
+if sys.version_info[:2] > (2, 6):
+ test_requirements.append("hypothesis>=1.11.4")
+
# If there's no vectors locally that probably means we are in a tarball and
# need to go and get the matching vectors package from PyPi