aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorPaul Kehrer <paul.l.kehrer@gmail.com>2014-01-20 13:38:36 -0600
committerPaul Kehrer <paul.l.kehrer@gmail.com>2014-01-20 13:38:36 -0600
commit1de55b76b12d7ade3e19f2c8e094695201d1523f (patch)
tree2e4537ec44634106da56a0bf38beab667e480dc4 /setup.py
parent5ab6a208c46f1de6e261646a0ad34482ea755922 (diff)
parentcd10571261ad24dcd0dc63c9703289faccd841a8 (diff)
downloadcryptography-1de55b76b12d7ade3e19f2c8e094695201d1523f.tar.gz
cryptography-1de55b76b12d7ade3e19f2c8e094695201d1523f.tar.bz2
cryptography-1de55b76b12d7ade3e19f2c8e094695201d1523f.zip
Merge branch 'master' into commoncrypto-cipher-backend
* master: expand tox backend example On OS X at build time compile the CC bindings fix docs update docs for name attribute revert fixture decorator for now, switch to append. no more globals docs for explicit backend selection and document name attribute of backend modify backend selection to allow multiple backends via comma delimiter better name for the variable don't mutate _ALL_BACKENDS pass posargs via tox so --backend can be used for tox envs support --backend as a pytest flag to limit to one backend for testing
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py13
1 files changed, 11 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index e8bcc11f..57a95752 100644
--- a/setup.py
+++ b/setup.py
@@ -43,14 +43,23 @@ class cffi_build(build):
"""
def finalize_options(self):
- from cryptography.hazmat.bindings.openssl.binding import Binding
+ from cryptography.hazmat.bindings.commoncrypto.binding import (
+ Binding as CommonCryptoBinding
+ )
+ from cryptography.hazmat.bindings.openssl.binding import (
+ Binding as OpenSSLBinding
+ )
from cryptography.hazmat.primitives import constant_time, padding
self.distribution.ext_modules = [
- Binding().ffi.verifier.get_extension(),
+ OpenSSLBinding().ffi.verifier.get_extension(),
constant_time._ffi.verifier.get_extension(),
padding._ffi.verifier.get_extension()
]
+ if CommonCryptoBinding.is_available():
+ self.distribution.ext_modules.append(
+ CommonCryptoBinding().ffi.verifier.get_extension()
+ )
build.finalize_options(self)