aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorPaul Kehrer <paul.l.kehrer@gmail.com>2014-01-11 20:04:37 -0600
committerPaul Kehrer <paul.l.kehrer@gmail.com>2014-01-11 20:04:37 -0600
commit23d569e1eb03c44688f91377223e97df53291c13 (patch)
tree36686e8cd298b0e883a72562f6d4715bf102d8ed /setup.py
parentb53e5a05f199b48de9f2f52afd29be4b9c876595 (diff)
parentfa4700006ea1eb45387f2f4f0493ad07f78d1ad9 (diff)
downloadcryptography-23d569e1eb03c44688f91377223e97df53291c13.tar.gz
cryptography-23d569e1eb03c44688f91377223e97df53291c13.tar.bz2
cryptography-23d569e1eb03c44688f91377223e97df53291c13.zip
Merge branch 'master' into common-crypto-backend
* master: Use pytest.fixture for backends drop to >= 0.8 to make pypy happy change to anonymous enum require cffi >= 0.8.1 remove extraneous spaces add hmac to commoncrypto binding bytes byte back add check to confirm we've loaded error strings Bind all the PEM errors Spelling! oops, bytes plz don't leak a context in the test add tests to the openssl backend to verify that we've registered Nonsense I think we need. This is a dep init the ssl library in the backend Actuall install a thing Try to run the spellchecker on travis Use a normal quote here, not sure where the smart quote came from Expose ERR_load_SSL_strings
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index feed0cd8..e8bcc11f 100644
--- a/setup.py
+++ b/setup.py
@@ -23,7 +23,7 @@ with open(os.path.join(base_dir, "cryptography", "__about__.py")) as f:
exec(f.read(), about)
-CFFI_DEPENDENCY = "cffi>=0.6"
+CFFI_DEPENDENCY = "cffi>=0.8"
SIX_DEPENDENCY = "six>=1.4.1"
requirements = [