aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorDonald Stufft <donald@stufft.io>2013-08-11 17:38:13 -0400
committerDonald Stufft <donald@stufft.io>2013-08-11 17:38:13 -0400
commit446a457218e3f793f4fec6b73e719c37bfef7d6e (patch)
treeff8636929592945493350a70bea0c3df1e3f0f8a /setup.py
parentb19736c8ffdb2bfe243097cae55b60d855e7a0fe (diff)
parent09f53578923c241fbb76c0be6bdf725f3b96f528 (diff)
downloadcryptography-446a457218e3f793f4fec6b73e719c37bfef7d6e.tar.gz
cryptography-446a457218e3f793f4fec6b73e719c37bfef7d6e.tar.bz2
cryptography-446a457218e3f793f4fec6b73e719c37bfef7d6e.zip
Merge branch 'master' into simple-symmetric-encryption
Conflicts: setup.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py59
1 files changed, 56 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 8fd8a724..a1305d2f 100644
--- a/setup.py
+++ b/setup.py
@@ -12,7 +12,23 @@
# limitations under the License.
import sys
-from setuptools import setup
+from setuptools import setup, find_packages
+
+
+about = {}
+with open("cryptography/__about__.py") as fp:
+ exec(fp.read(), about)
+
+
+CFFI_DEPENDENCY = "cffi>=0.6"
+
+install_requires = [
+ CFFI_DEPENDENCY,
+]
+
+setup_requires = [
+ CFFI_DEPENDENCY,
+]
install_requires = [
"cffi>=0.6",
@@ -22,7 +38,44 @@ if sys.version_info[:2] < (3, 4):
install_requires += ["enum34"]
setup(
- name="cryptography",
- license="Apache License, Version 2.0",
+ name=about["__title__"],
+ version=about["__version__"],
+
+ description=about["__summary__"],
+ license=about["__license__"],
+ url=about["__uri__"],
+
+ author=about["__author__"],
+ author_email=about["__email__"],
+
+ classifiers=[
+ "Development Status :: 2 - Pre-Alpha",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: Apache Software License",
+ "Natural Language :: English",
+ "Operating System :: MacOS :: MacOS X",
+ "Operating System :: POSIX",
+ "Operating System :: POSIX :: BSD",
+ "Operating System :: POSIX :: Linux",
+ "Operating System :: Microsoft :: Windows",
+ #"Programming Language :: cffi",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 2.6",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.2",
+ "Programming Language :: Python :: 3.3",
+ "Programming Language :: Python :: Implementation :: CPython",
+ "Programming Language :: Python :: Implementation :: PyPy",
+ "Topic :: Security :: Cryptography",
+ ],
+
+ packages=find_packages(exclude=["tests", "tests.*"]),
+
install_requires=install_requires,
+ setup_requires=setup_requires,
+
+ # for cffi
+ zip_safe=False,
)