aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorPaul Kehrer <paul.l.kehrer@gmail.com>2014-12-18 07:42:27 -0600
committerPaul Kehrer <paul.l.kehrer@gmail.com>2014-12-18 07:47:34 -0600
commit5bea5ca0233be05e09d8c62fdeae86187e73a48e (patch)
treed3949e053b144e7a358c295570bb76c3c88faa1b /setup.py
parent9cde70ae840685f2bae6173b6beb192ae3866dc3 (diff)
downloadcryptography-5bea5ca0233be05e09d8c62fdeae86187e73a48e.tar.gz
cryptography-5bea5ca0233be05e09d8c62fdeae86187e73a48e.tar.bz2
cryptography-5bea5ca0233be05e09d8c62fdeae86187e73a48e.zip
make enum34 installation conditional on python < 3.4
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index ead5ec4f..32a87ba3 100644
--- a/setup.py
+++ b/setup.py
@@ -36,12 +36,14 @@ VECTORS_DEPENDENCY = "cryptography_vectors=={0}".format(about['__version__'])
requirements = [
CFFI_DEPENDENCY,
- "enum34",
"pyasn1",
SIX_DEPENDENCY,
SETUPTOOLS_DEPENDENCY
]
+if sys.version_info < (3, 4):
+ requirements.append("enum34")
+
# If you add a new dep here you probably need to add it in the tox.ini as well
test_requirements = [
"pytest",