diff options
author | Hynek Schlawack <hs@ox.cx> | 2013-09-07 12:14:31 -0700 |
---|---|---|
committer | Hynek Schlawack <hs@ox.cx> | 2013-09-07 12:14:31 -0700 |
commit | 5e00e96f20f8c70614b463015e64a277a4348576 (patch) | |
tree | 416db58071e8bc6ad51f613e7c01edb9cfb6ae64 /setup.py | |
parent | a53f81dbb49a8504559e9d8ef7e2dd386c15ed41 (diff) | |
parent | aaa22171618e18888d0a0487d4564bcdae5c2015 (diff) | |
download | cryptography-5e00e96f20f8c70614b463015e64a277a4348576.tar.gz cryptography-5e00e96f20f8c70614b463015e64a277a4348576.tar.bz2 cryptography-5e00e96f20f8c70614b463015e64a277a4348576.zip |
Merge pull request #28 from alex/simple-symmetric-encryption
[WIP] initial implementation of symmetric encryption
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 6 |
1 files changed, 5 insertions, 1 deletions
@@ -10,8 +10,11 @@ # implied. # See the License for the specific language governing permissions and # limitations under the License. +import sys + from setuptools import setup, find_packages + about = {} with open("cryptography/__about__.py") as fp: exec(fp.read(), about) @@ -27,6 +30,8 @@ setup_requires = [ CFFI_DEPENDENCY, ] +if sys.version_info[:2] < (3, 4): + install_requires += ["enum34"] setup( name=about["__title__"], @@ -49,7 +54,6 @@ setup( "Operating System :: POSIX :: BSD", "Operating System :: POSIX :: Linux", "Operating System :: Microsoft :: Windows", - #"Programming Language :: cffi", "Programming Language :: Python", "Programming Language :: Python :: 2", "Programming Language :: Python :: 2.6", |