aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAlex Gaynor <alex.gaynor@gmail.com>2014-01-07 12:27:08 -0800
committerAlex Gaynor <alex.gaynor@gmail.com>2014-01-07 12:27:08 -0800
commit5e5316de9ca968f646aa04301fcf3109aef0473f (patch)
tree0bfcb081074648c95356508df5b5323b484a4d00 /setup.py
parentd7e04ae2f45c99034d564fd6a7747bf216d00ea9 (diff)
downloadcryptography-5e5316de9ca968f646aa04301fcf3109aef0473f.tar.gz
cryptography-5e5316de9ca968f646aa04301fcf3109aef0473f.tar.bz2
cryptography-5e5316de9ca968f646aa04301fcf3109aef0473f.zip
This is dangerous
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 1 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index a053fe61..feed0cd8 100644
--- a/setup.py
+++ b/setup.py
@@ -47,13 +47,10 @@ class cffi_build(build):
from cryptography.hazmat.primitives import constant_time, padding
self.distribution.ext_modules = [
+ Binding().ffi.verifier.get_extension(),
constant_time._ffi.verifier.get_extension(),
padding._ffi.verifier.get_extension()
]
- if Binding.is_available():
- self.distribution.ext_modules.append(
- Binding().ffi.verifier.get_extension()
- )
build.finalize_options(self)