aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorDonald Stufft <donald@stufft.io>2013-08-11 16:37:43 -0400
committerDonald Stufft <donald@stufft.io>2013-08-11 17:29:12 -0400
commit5f12a1b89a46f028582945dff23a97c53e8ae2c5 (patch)
treee10676c8072f059a54f1e33e730f36c0e155bd8f /setup.py
parente61e5b704457cdb36034aff0d904e4b2dff95b0b (diff)
downloadcryptography-5f12a1b89a46f028582945dff23a97c53e8ae2c5.tar.gz
cryptography-5f12a1b89a46f028582945dff23a97c53e8ae2c5.tar.bz2
cryptography-5f12a1b89a46f028582945dff23a97c53e8ae2c5.zip
Fix the packaging meta-data
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py41
1 files changed, 32 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index fe23f302..7fe90d9c 100644
--- a/setup.py
+++ b/setup.py
@@ -10,18 +10,35 @@
# implied.
# See the License for the specific language governing permissions and
# limitations under the License.
-
from setuptools import setup
+about = {}
+with open("cryptography/__about__.py") as fp:
+ exec(fp.read(), about)
+
+
+CFFI_DEPENDENCY = "cffi>=0.6"
+
+install_requires = [
+ CFFI_DEPENDENCY,
+]
+
+setup_requires = [
+ CFFI_DEPENDENCY,
+]
+
+
setup(
- name="cryptography",
- description="cryptography is a package designed to expose cryptographic "
- "primitives and recipes to Python developers.",
- license="Apache License, Version 2.0",
- url="https://github.com/alex/cryptography",
- # for cffi
- zip_safe=False,
- setup_requires=["cffi>=0.6"],
+ name=about["__title__"],
+ version=about["__version__"],
+
+ description=about["__summary__"],
+ license=about["__license__"],
+ url=about["__uri__"],
+
+ author=about["__author__"],
+ author_email=about["__email__"],
+
classifiers=[
"Development Status :: 2 - Pre-Alpha",
"Intended Audience :: Developers",
@@ -44,4 +61,10 @@ setup(
"Programming Language :: Python :: Implementation :: PyPy",
"Topic :: Security :: Cryptography",
],
+
+ install_requires=install_requires,
+ setup_requires=setup_requires,
+
+ # for cffi
+ zip_safe=False,
)