diff options
author | Paul Kehrer <paul.l.kehrer@gmail.com> | 2014-01-11 21:59:08 -0600 |
---|---|---|
committer | Paul Kehrer <paul.l.kehrer@gmail.com> | 2014-01-11 21:59:08 -0600 |
commit | 74169660e47b760f82c0653b4210b3bc5d3bf46b (patch) | |
tree | 33835b3e733f6b918b56240200e29402092cc384 /setup.py | |
parent | 9ad4d755bb3a2edfb8e46b60f6dfaff6365f0386 (diff) | |
parent | 089a860f2d3f0ac923fc3f78190055990a940e2a (diff) | |
download | cryptography-74169660e47b760f82c0653b4210b3bc5d3bf46b.tar.gz cryptography-74169660e47b760f82c0653b4210b3bc5d3bf46b.tar.bz2 cryptography-74169660e47b760f82c0653b4210b3bc5d3bf46b.zip |
Merge branch 'master' into urandom-engine
* master: (169 commits)
Make just one call to ffi.cdef for most of the definitions
Use pytest.fixture for backends
drop to >= 0.8 to make pypy happy
change to anonymous enum
require cffi >= 0.8.1
remove extraneous spaces
add hmac to commoncrypto binding
bytes byte back
add check to confirm we've loaded error strings
Bind all the PEM errors
Spelling!
oops, bytes plz
don't leak a context in the test
add tests to the openssl backend to verify that we've registered
Nonsense I think we need.
This is a dep
init the ssl library in the backend
Actuall install a thing
Try to run the spellchecker on travis
Use a normal quote here, not sure where the smart quote came from
...
Conflicts:
cryptography/hazmat/bindings/openssl/binding.py
tests/hazmat/backends/test_openssl.py
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 52 |
1 files changed, 43 insertions, 9 deletions
@@ -10,31 +10,61 @@ # implied. # See the License for the specific language governing permissions and # limitations under the License. +import os +from distutils.command.build import build + from setuptools import setup, find_packages +base_dir = os.path.dirname(__file__) + about = {} -with open("cryptography/__about__.py") as fp: - exec(fp.read(), about) +with open(os.path.join(base_dir, "cryptography", "__about__.py")) as f: + exec(f.read(), about) -CFFI_DEPENDENCY = "cffi>=0.6" +CFFI_DEPENDENCY = "cffi>=0.8" SIX_DEPENDENCY = "six>=1.4.1" -install_requires = [ +requirements = [ CFFI_DEPENDENCY, SIX_DEPENDENCY ] -setup_requires = [ - CFFI_DEPENDENCY, -] + +class cffi_build(build): + """ + This class exists, instead of just providing ``ext_modules=[...]`` directly + in ``setup()`` because importing cryptography requires we have several + packages installed first. + + By doing the imports here we ensure that packages listed in + ``setup_requires`` are already installed. + """ + + def finalize_options(self): + from cryptography.hazmat.bindings.openssl.binding import Binding + from cryptography.hazmat.primitives import constant_time, padding + + self.distribution.ext_modules = [ + Binding().ffi.verifier.get_extension(), + constant_time._ffi.verifier.get_extension(), + padding._ffi.verifier.get_extension() + ] + + build.finalize_options(self) + + +with open(os.path.join(base_dir, "README.rst")) as f: + long_description = f.read() + setup( name=about["__title__"], version=about["__version__"], description=about["__summary__"], + long_description=long_description, license=about["__license__"], url=about["__uri__"], @@ -65,9 +95,13 @@ setup( packages=find_packages(exclude=["tests", "tests.*"]), - install_requires=install_requires, - setup_requires=setup_requires, + install_requires=requirements, + setup_requires=requirements, # for cffi zip_safe=False, + ext_package="cryptography", + cmdclass={ + "build": cffi_build, + } ) |