diff options
author | Alex Gaynor <alex.gaynor@gmail.com> | 2015-03-08 22:14:31 -0400 |
---|---|---|
committer | Alex Gaynor <alex.gaynor@gmail.com> | 2015-03-08 22:14:31 -0400 |
commit | 930fc6a24e890ac1ed044985eaf82118db542617 (patch) | |
tree | b1011c9a267b9ba0d44ffdaf093845fccfaa8206 /setup.py | |
parent | 785cb422767cb7a99fa71d28e2e2e13b16f35c90 (diff) | |
parent | 4cf381137643c2d78e8631f3f439daef62a97a67 (diff) | |
download | cryptography-930fc6a24e890ac1ed044985eaf82118db542617.tar.gz cryptography-930fc6a24e890ac1ed044985eaf82118db542617.tar.bz2 cryptography-930fc6a24e890ac1ed044985eaf82118db542617.zip |
Merge pull request #1695 from Julian/master
Remove the CFFI requirement, which breaks pip install -U on PyPy
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 4 |
1 files changed, 3 insertions, 1 deletions
@@ -35,7 +35,6 @@ SIX_DEPENDENCY = "six>=1.4.1" VECTORS_DEPENDENCY = "cryptography_vectors=={0}".format(about['__version__']) requirements = [ - CFFI_DEPENDENCY, "pyasn1", SIX_DEPENDENCY, SETUPTOOLS_DEPENDENCY @@ -44,6 +43,9 @@ requirements = [ if sys.version_info < (3, 4): requirements.append("enum34") +if platform.python_implementation() != "PyPy": + requirements.append(CFFI_DEPENDENCY) + # If you add a new dep here you probably need to add it in the tox.ini as well test_requirements = [ "pytest", |