aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorDonald Stufft <donald@stufft.io>2013-08-10 15:43:51 -0400
committerDonald Stufft <donald@stufft.io>2013-08-10 15:44:36 -0400
commitbac187d7e1c7c3bb2f2968f5c36bdcd03d7ce3a1 (patch)
tree8081c434b2179e053f97974b310a085615290699 /setup.py
parent93b1df6049c5b80c336153a7be0e3485fa2611bc (diff)
downloadcryptography-bac187d7e1c7c3bb2f2968f5c36bdcd03d7ce3a1.tar.gz
cryptography-bac187d7e1c7c3bb2f2968f5c36bdcd03d7ce3a1.tar.bz2
cryptography-bac187d7e1c7c3bb2f2968f5c36bdcd03d7ce3a1.zip
Use an enum for determining BlockCipher operation
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 8 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index c3b754f3..8fd8a724 100644
--- a/setup.py
+++ b/setup.py
@@ -10,12 +10,19 @@
# implied.
# See the License for the specific language governing permissions and
# limitations under the License.
+import sys
from setuptools import setup
+install_requires = [
+ "cffi>=0.6",
+]
+
+if sys.version_info[:2] < (3, 4):
+ install_requires += ["enum34"]
setup(
name="cryptography",
license="Apache License, Version 2.0",
- install_requires=["cffi>=0.6"],
+ install_requires=install_requires,
)