aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorTerry Chia <terrycwk1994@gmail.com>2014-07-27 12:27:52 +0800
committerTerry Chia <terrycwk1994@gmail.com>2014-07-27 12:27:52 +0800
commitda5dca8a92dfe8e01c5f88c67fd78d37cd6a7d22 (patch)
tree4623c3f938868ec54a12bd7e16eda71ad71869da /setup.py
parent3319c95bf861f806a1b237c99661b30379389063 (diff)
downloadcryptography-da5dca8a92dfe8e01c5f88c67fd78d37cd6a7d22.tar.gz
cryptography-da5dca8a92dfe8e01c5f88c67fd78d37cd6a7d22.tar.bz2
cryptography-da5dca8a92dfe8e01c5f88c67fd78d37cd6a7d22.zip
Added entry_points.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 15 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index f73394ee..30146b71 100644
--- a/setup.py
+++ b/setup.py
@@ -32,13 +32,15 @@ with open(os.path.join(base_dir, "cryptography", "__about__.py")) as f:
exec(f.read(), about)
+SETUPTOOLS_DEPENDENCY = "setuptools"
CFFI_DEPENDENCY = "cffi>=0.8"
SIX_DEPENDENCY = "six>=1.4.1"
VECTORS_DEPENDENCY = "cryptography_vectors=={0}".format(about['__version__'])
requirements = [
CFFI_DEPENDENCY,
- SIX_DEPENDENCY
+ SIX_DEPENDENCY,
+ SETUPTOOLS_DEPENDENCY
]
# If you add a new dep here you probably need to add it in the tox.ini as well
@@ -173,5 +175,17 @@ setup(
"build": CFFIBuild,
"install": CFFIInstall,
"test": PyTest,
+ },
+
+ entry_points={
+ "cryptography.hazmat.backends": [
+ "commoncrypto = cryptography.hazmat.backends.commoncrypto:backend",
+ "openssl = cryptography.hazmat.backends.openssl:backend"
+ ],
+
+ "cryptography.hazmat.is_backend_available": [
+ "commoncrypto = cryptography.hazmat.bindings.commoncrypto."
+ "binding:Binding.is_available"
+ ]
}
)