aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAlex Gaynor <alex.gaynor@gmail.com>2014-01-03 07:33:01 -0800
committerAlex Gaynor <alex.gaynor@gmail.com>2014-01-03 07:33:01 -0800
commitf51f2c1c5f24f627cfe57c2ea6d821c87f7a6c20 (patch)
treeb33f4e477796b6b22f7084ad74339fe8229b7ae3 /setup.py
parentc39559c6d629d68674d240d6e6bcdf44a15d90cf (diff)
downloadcryptography-f51f2c1c5f24f627cfe57c2ea6d821c87f7a6c20.tar.gz
cryptography-f51f2c1c5f24f627cfe57c2ea6d821c87f7a6c20.tar.bz2
cryptography-f51f2c1c5f24f627cfe57c2ea6d821c87f7a6c20.zip
Include a long description in our setup.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 7 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 1856cadb..e2df1c46 100644
--- a/setup.py
+++ b/setup.py
@@ -10,6 +10,8 @@
# implied.
# See the License for the specific language governing permissions and
# limitations under the License.
+import os
+
from setuptools import setup, find_packages
@@ -30,11 +32,16 @@ setup_requires = [
CFFI_DEPENDENCY,
]
+with open(os.path.join(os.path.dirname(__file__), "README.rst")) as f:
+ long_description = f.read()
+
+
setup(
name=about["__title__"],
version=about["__version__"],
description=about["__summary__"],
+ long_description=long_description,
license=about["__license__"],
url=about["__uri__"],