aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorChristian Heimes <christian@cheimes.de>2013-08-10 23:28:29 +0200
committerChristian Heimes <christian@cheimes.de>2013-08-10 23:28:29 +0200
commitf83ed1d8afc2cf8cee2a02496ae3cc3cdb3aee77 (patch)
treec9bcccdf9c8a21abdd2804adcd340c96056a99bf /setup.py
parentccc5062166f673c0b572c4e3344c8f5a61661d50 (diff)
downloadcryptography-f83ed1d8afc2cf8cee2a02496ae3cc3cdb3aee77.tar.gz
cryptography-f83ed1d8afc2cf8cee2a02496ae3cc3cdb3aee77.tar.bz2
cryptography-f83ed1d8afc2cf8cee2a02496ae3cc3cdb3aee77.zip
add classifiers, url, description and nose integration for python setup.py test
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py27
1 files changed, 27 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index c3b754f3..d162958b 100644
--- a/setup.py
+++ b/setup.py
@@ -18,4 +18,31 @@ setup(
name="cryptography",
license="Apache License, Version 2.0",
install_requires=["cffi>=0.6"],
+ setup_requires=["nose>=1.0"],
+ test_suite="nose.collector",
+ url="https://github.com/alex/cryptography",
+ description="cryptography is a package designed to expose cryptographic "
+ "primitives and recipes to Python developers.",
+ classifiers=[
+ "Development Status :: 2 - Pre-Alpha",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: Apache Software License",
+ "Natural Language :: English",
+ "Operating System :: MacOS :: MacOS X",
+ "Operating System :: POSIX",
+ "Operating System :: POSIX :: BSD",
+ "Operating System :: POSIX :: Linux",
+ "Operating System :: Microsoft :: Windows",
+ "Programming Language :: C",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 2.6",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.2",
+ "Programming Language :: Python :: 3.3",
+ "Programming Language :: Python :: Implementation :: CPython",
+ "Programming Language :: Python :: Implementation :: PyPy",
+ "Topic :: Security :: Cryptography",
+ ],
)