aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorChristian Heimes <christian@python.org>2013-08-11 15:33:51 +0200
committerChristian Heimes <christian@python.org>2013-08-11 15:33:51 +0200
commitff1e64fd4ad32227f34e6ff2210c56e1a3db0d7d (patch)
treefe19d61d24c242230bb45f5eeccfd94ae0eb1edc /setup.py
parente2a82eaa8762c88134302674955b31d843249a19 (diff)
downloadcryptography-ff1e64fd4ad32227f34e6ff2210c56e1a3db0d7d.tar.gz
cryptography-ff1e64fd4ad32227f34e6ff2210c56e1a3db0d7d.tar.bz2
cryptography-ff1e64fd4ad32227f34e6ff2210c56e1a3db0d7d.zip
drop setup.py test again
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 0 insertions, 16 deletions
diff --git a/setup.py b/setup.py
index 2b935340..7fc10b4c 100644
--- a/setup.py
+++ b/setup.py
@@ -13,20 +13,6 @@
import sys
from setuptools import setup
-from setuptools.command.test import test as TestCommand
-
-
-class PyTest(TestCommand):
- def finalize_options(self):
- TestCommand.finalize_options(self)
- self.test_args = []
- self.test_suite = True
-
- def run_tests(self):
- import pytest
- errno = pytest.main(self.test_args)
- sys.exit(errno)
-
setup(
name="cryptography",
@@ -36,8 +22,6 @@ setup(
url="https://github.com/alex/cryptography",
zip_safe=False, # for cffi
setup_requires=["cffi>=0.6"],
- tests_require=["pytest"],
- cmdclass = {"test": PyTest},
classifiers=[
"Development Status :: 2 - Pre-Alpha",
"Intended Audience :: Developers",