aboutsummaryrefslogtreecommitdiffstats
path: root/tasks.py
diff options
context:
space:
mode:
authorDavid Reid <dreid@dreid.org>2014-01-07 12:18:38 -0800
committerDavid Reid <dreid@dreid.org>2014-01-07 12:18:38 -0800
commit168c29d6d74060b0d9f592b740f8913cc5d07c5e (patch)
tree7a8c94b417cf4bad7ab18b029f25aaaea678c1ed /tasks.py
parent7507a1a7692ec7e26817d93dbcea3911eae3864b (diff)
parent41c14d55ea2d17e3e9968acfa93d442615f7cda0 (diff)
downloadcryptography-168c29d6d74060b0d9f592b740f8913cc5d07c5e.tar.gz
cryptography-168c29d6d74060b0d9f592b740f8913cc5d07c5e.tar.bz2
cryptography-168c29d6d74060b0d9f592b740f8913cc5d07c5e.zip
Merge pull request #410 from alex/release-automation
Write release automation software. Fixes #375
Diffstat (limited to 'tasks.py')
-rw-r--r--tasks.py27
1 files changed, 27 insertions, 0 deletions
diff --git a/tasks.py b/tasks.py
new file mode 100644
index 00000000..f72f43ba
--- /dev/null
+++ b/tasks.py
@@ -0,0 +1,27 @@
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+# implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+from __future__ import absolute_import, division, print_function
+
+import invoke
+
+
+@invoke.task
+def release(version):
+ """
+ ``version`` should be a string like '0.4' or '1.0'.
+ """
+ invoke.run("git tag -s {0}".format(version))
+ invoke.run("git push --tags")
+
+ invoke.run("python setup.py sdist")
+ invoke.run("twine upload -s dist/cryptography-{0}*".format(version))