aboutsummaryrefslogtreecommitdiffstats
path: root/tasks.py
diff options
context:
space:
mode:
authorAlex Gaynor <alex.gaynor@gmail.com>2014-02-19 14:01:06 -0800
committerAlex Gaynor <alex.gaynor@gmail.com>2014-02-19 14:01:06 -0800
commit86201594026f1e505b746633eeedd4a5820d4d89 (patch)
tree5c7052f5611e66ec9ff0a69759d7bf609551b6a6 /tasks.py
parent6d869c1b2fdc9dc20f90a5b520896b01a0f9011b (diff)
downloadcryptography-86201594026f1e505b746633eeedd4a5820d4d89.tar.gz
cryptography-86201594026f1e505b746633eeedd4a5820d4d89.tar.bz2
cryptography-86201594026f1e505b746633eeedd4a5820d4d89.zip
Refs #506 -- Trigger creation of wheels when doing a release
Diffstat (limited to 'tasks.py')
-rw-r--r--tasks.py15
1 files changed, 15 insertions, 0 deletions
diff --git a/tasks.py b/tasks.py
index f72f43ba..4b2209af 100644
--- a/tasks.py
+++ b/tasks.py
@@ -12,8 +12,14 @@
# limitations under the License.
from __future__ import absolute_import, division, print_function
+import getpass
+
import invoke
+import requests
+
+
+JENKINS_ROOT = "http://jenkins.cryptography.io"
@invoke.task
def release(version):
@@ -25,3 +31,12 @@ def release(version):
invoke.run("python setup.py sdist")
invoke.run("twine upload -s dist/cryptography-{0}*".format(version))
+
+ token = getpass.getpass("Input the Jenkins token")
+ requests.post(
+ "{0}/job/cryptography-wheel-builder/build".format(JENKINS_ROOT),
+ params={
+ "token": token,
+ "cause": "Building wheels for {0}".format(version)
+ }
+ )