aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index ead5ec4f..32a87ba3 100644
--- a/setup.py
+++ b/setup.py
@@ -36,12 +36,14 @@ VECTORS_DEPENDENCY = "cryptography_vectors=={0}".format(about['__version__'])
requirements = [
CFFI_DEPENDENCY,
- "enum34",
"pyasn1",
SIX_DEPENDENCY,
SETUPTOOLS_DEPENDENCY
]
+if sys.version_info < (3, 4):
+ requirements.append("enum34")
+
# If you add a new dep here you probably need to add it in the tox.ini as well
test_requirements = [
"pytest",