aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--MANIFEST.in2
-rw-r--r--pyproject.toml7
-rw-r--r--setup.py1
3 files changed, 10 insertions, 0 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index b05a869c..373c2420 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -6,6 +6,8 @@ include LICENSE.APACHE
include LICENSE.BSD
include README.rst
+include pyproject.toml
+
recursive-include docs *
recursive-include src/_cffi_src *.py *.c *.h
prune docs/_build
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 00000000..461675f0
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,7 @@
+[build-system]
+# Must be kept in sync with `setup_requirements` in `setup.py`
+requires = [
+ "setuptools>=18.5",
+ "wheel",
+ "cffi>=1.7,!=1.11.3; python_implementation != 'PyPy'",
+]
diff --git a/setup.py b/setup.py
index 2fbbd046..8bd31bd5 100644
--- a/setup.py
+++ b/setup.py
@@ -43,6 +43,7 @@ with open(os.path.join(src_dir, "cryptography", "__about__.py")) as f:
VECTORS_DEPENDENCY = "cryptography_vectors=={0}".format(about['__version__'])
+# `setup_requirements` must be kept in sync with `pyproject.toml`
setup_requirements = ["cffi>=1.7,!=1.11.3"]
if platform.python_implementation() == "PyPy":