aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.jenkins/Jenkinsfile-cryptography-wheel-builder17
1 files changed, 4 insertions, 13 deletions
diff --git a/.jenkins/Jenkinsfile-cryptography-wheel-builder b/.jenkins/Jenkinsfile-cryptography-wheel-builder
index 1cd76417..5f98276c 100644
--- a/.jenkins/Jenkinsfile-cryptography-wheel-builder
+++ b/.jenkins/Jenkinsfile-cryptography-wheel-builder
@@ -111,18 +111,14 @@ def build(version, label, imageName) {
source .venv/bin/activate
pip install -U wheel # upgrade wheel to latest before we use it to build the wheel
pip install cffi six idna asn1crypto ipaddress enum34
- pip download cryptography==$BUILD_VERSION --no-binary cryptography --no-deps
- tar zxf cryptography*
- pushd cryptography*
REGEX="py3([0-9])*"
if [[ "${version}" =~ \$REGEX ]]; then
- PY_LIMITED_API="--py-limited-api=cp3\${BASH_REMATCH[1]}"
+ PY_LIMITED_API="--build-option --py-limited-api=cp3\${BASH_REMATCH[1]}"
fi
CRYPTOGRAPHY_SUPPRESS_LINK_FLAGS="1" \
LDFLAGS="/usr/local/opt/openssl@1.1/lib/libcrypto.a /usr/local/opt/openssl@1.1/lib/libssl.a" \
CFLAGS="-I/usr/local/opt/openssl@1.1/include -mmacosx-version-min=10.9" \
- python setup.py bdist_wheel --dist-dir=../wheelhouse \$PY_LIMITED_API
- popd
+ pip wheel cryptography==$BUILD_VERSION --wheel-dir=wheelhouse --no-binary cryptography --no-deps \$PY_LIMITED_API
pip install -f wheelhouse cryptography --no-index
python -c "from cryptography.hazmat.backends.openssl.backend import backend;print('Loaded: ' + backend.openssl_version_text());print('Linked Against: ' + backend._ffi.string(backend._lib.OPENSSL_VERSION_TEXT).decode('ascii'))"
otool -L `find .venv -name '_openssl*.so'`
@@ -139,8 +135,6 @@ def build(version, label, imageName) {
set -x -e
$linux32 /opt/python/$version/bin/pip install cffi six idna asn1crypto ipaddress enum34
- $linux32 /opt/python/$version/bin/pip download cryptography==$BUILD_VERSION --no-binary cryptography --no-deps
- tar zxf cryptography*
# Because we are doing this as root in the container, but we write to a mounted dir that is outside the container
# we need to make sure we set these files writable such that the jenkins user can delete them afterwards
mkdir -p tmpwheelhouse
@@ -148,16 +142,13 @@ def build(version, label, imageName) {
chmod -R 777 tmpwheelhouse
chmod -R 777 wheelhouse
- pushd cryptography*
REGEX="cp3([0-9])*"
if [[ "${version}" =~ \$REGEX ]]; then
- PY_LIMITED_API="--py-limited-api=cp3\${BASH_REMATCH[1]}"
+ PY_LIMITED_API="--build-option --py-limited-api=cp3\${BASH_REMATCH[1]}"
fi
LDFLAGS="-L/opt/pyca/cryptography/openssl/lib" \
CFLAGS="-I/opt/pyca/cryptography/openssl/include -Wl,--exclude-libs,ALL" \
- $linux32 /opt/python/$version/bin/python setup.py bdist_wheel --dist-dir=../tmpwheelhouse \$PY_LIMITED_API
- popd
- chmod -R 777 cryptography*
+ $linux32 /opt/python/$version/bin/pip wheel cryptography==$BUILD_VERSION --no-binary cryptography --no-deps --wheel-dir=tmpwheelhouse \$PY_LIMITED_API
$linux32 auditwheel repair tmpwheelhouse/cryptography*.whl -w wheelhouse/
unzip wheelhouse/*.whl -d execstack.check
chmod -R 777 execstack.check