aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.travis.yml1
-rw-r--r--tox.ini6
2 files changed, 6 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
index f4c40470..3840f486 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -22,6 +22,7 @@ env:
- TOX_ENV=docs
- TOX_ENV=pep8
- TOX_ENV=py3pep8
+ - TOX_ENV=doc8
install:
- ./.travis/install.sh
diff --git a/tox.ini b/tox.ini
index e7d168d6..53e277a5 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py26,py27,pypy,py32,py33,py34,docs,pep8,py3pep8
+envlist = py26,py27,pypy,py32,py33,py34,docs,pep8,py3pep8,doc8
[testenv]
# If you add a new dep here you probably need to add it in setup.py as well
@@ -55,6 +55,10 @@ deps =
pep8-naming
commands = flake8 .
+[testenv:doc8]
+deps = doc8
+commands = doc8 README.rst docs/
+
[flake8]
exclude = .tox,*.egg
select = E,W,F,N,I