aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.travis.yml7
-rw-r--r--tox.ini13
2 files changed, 6 insertions, 14 deletions
diff --git a/.travis.yml b/.travis.yml
index e882403a..cacd1e27 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -22,7 +22,6 @@ env:
- TOX_ENV=docs
- TOX_ENV=pep8
- TOX_ENV=py3pep8
- - TOX_ENV=doc8
install:
- ./.travis/install.sh
@@ -50,9 +49,6 @@ matrix:
- os: osx
env: TOX_ENV=py3pep8
compiler: clang
- - os: osx
- env: TOX_ENV=doc8
- compiler: clang
- os: linux
env: TOX_ENV=docs
@@ -63,6 +59,3 @@ matrix:
- os: linux
env: TOX_ENV=py3pep8
compiler: clang
- - os: linux
- env: TOX_ENV=doc8
- compiler: clang
diff --git a/tox.ini b/tox.ini
index 53e277a5..db9b17cb 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py26,py27,pypy,py32,py33,py34,docs,pep8,py3pep8,doc8
+envlist = py26,py27,pypy,py32,py33,py34,docs,pep8,py3pep8
[testenv]
# If you add a new dep here you probably need to add it in setup.py as well
@@ -42,23 +42,22 @@ commands =
[testenv:pep8]
deps =
+ doc8
flake8
flake8-import-order
pep8-naming
-commands = flake8 .
+commands =
+ flake8 .
+ doc8 README.rst docs/
[testenv:py3pep8]
-basepython = python3.3
+basepython = python3
deps =
flake8
flake8-import-order
pep8-naming
commands = flake8 .
-[testenv:doc8]
-deps = doc8
-commands = doc8 README.rst docs/
-
[flake8]
exclude = .tox,*.egg
select = E,W,F,N,I