aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore3
-rw-r--r--AUTHORS.rst2
-rw-r--r--setup.py30
3 files changed, 33 insertions, 2 deletions
diff --git a/.gitignore b/.gitignore
index 2bf40e7c..886683e3 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,3 +4,6 @@ _build/
.tox/
*.egg-info/
.coverage
+cffi-*.egg/
+pycparser-*.egg/
+pytest-*.egg/
diff --git a/AUTHORS.rst b/AUTHORS.rst
index 06e23d1f..3438aa04 100644
--- a/AUTHORS.rst
+++ b/AUTHORS.rst
@@ -5,3 +5,5 @@ AUTHORS
* Hynek Schlawack <hs@ox.cx>
* Donald Stufft <donald@stufft.io>
* Laurens Van Houtven <_@lvh.io>
+* Christian Heimes <christian@python.org>
+
diff --git a/setup.py b/setup.py
index c3b754f3..fe23f302 100644
--- a/setup.py
+++ b/setup.py
@@ -13,9 +13,35 @@
from setuptools import setup
-
setup(
name="cryptography",
+ description="cryptography is a package designed to expose cryptographic "
+ "primitives and recipes to Python developers.",
license="Apache License, Version 2.0",
- install_requires=["cffi>=0.6"],
+ url="https://github.com/alex/cryptography",
+ # for cffi
+ zip_safe=False,
+ setup_requires=["cffi>=0.6"],
+ classifiers=[
+ "Development Status :: 2 - Pre-Alpha",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: Apache Software License",
+ "Natural Language :: English",
+ "Operating System :: MacOS :: MacOS X",
+ "Operating System :: POSIX",
+ "Operating System :: POSIX :: BSD",
+ "Operating System :: POSIX :: Linux",
+ "Operating System :: Microsoft :: Windows",
+ #"Programming Language :: cffi",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 2.6",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.2",
+ "Programming Language :: Python :: 3.3",
+ "Programming Language :: Python :: Implementation :: CPython",
+ "Programming Language :: Python :: Implementation :: PyPy",
+ "Topic :: Security :: Cryptography",
+ ],
)