aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--setup.py12
1 files changed, 8 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index b0ad2db3..64e31cae 100644
--- a/setup.py
+++ b/setup.py
@@ -168,10 +168,14 @@ def keywords_with_side_effects(argv):
argv[1] in ('--help-commands', '--version', 'clean', 'egg_info')):
return {}
else:
- return dict(setup_requires=requirements,
- cmdclass=dict(build=CFFIBuild,
- install=CFFIInstall,
- test=PyTest))
+ return {
+ "setup_requires": requirements,
+ "cmdclass": {
+ "build": CFFIBuild,
+ "install": CFFIInstall,
+ "test": PyTest,
+ }
+ }
with open(os.path.join(base_dir, "README.rst")) as f: