aboutsummaryrefslogtreecommitdiffstats
path: root/Jenkinsfile
diff options
context:
space:
mode:
Diffstat (limited to 'Jenkinsfile')
-rw-r--r--Jenkinsfile130
1 files changed, 0 insertions, 130 deletions
diff --git a/Jenkinsfile b/Jenkinsfile
index ca49527c..44e9ab9b 100644
--- a/Jenkinsfile
+++ b/Jenkinsfile
@@ -103,114 +103,6 @@ if (env.BRANCH_NAME == "master") {
)
}
-def downstreams = [
- [
- downstreamName: 'pyOpenSSL',
- label: 'docker',
- imageName: 'pyca/cryptography-runner-ubuntu-rolling',
- script: """#!/bin/bash -xe
- git clone --depth=1 https://github.com/pyca/pyopenssl
- cd pyopenssl
- virtualenv .venv
- source .venv/bin/activate
- pip install ../cryptography
- pip install -e .[test]
- pytest tests
- """
- ],
- [
- downstreamName: 'Twisted',
- label: 'docker',
- imageName: 'pyca/cryptography-runner-ubuntu-rolling',
- script: """#!/bin/bash -xe
- git clone --depth=1 https://github.com/twisted/twisted
- cd twisted
- virtualenv .venv
- source .venv/bin/activate
- pip install ../cryptography
- pip install pyopenssl service_identity pycrypto
- pip install -e .
- python -m twisted.trial src/twisted
- """
- ],
- [
- downstreamName: 'paramiko',
- label: 'docker',
- imageName: 'pyca/cryptography-runner-ubuntu-rolling',
- script: """#!/bin/bash -xe
- git clone --depth=1 https://github.com/paramiko/paramiko
- cd paramiko
- virtualenv .venv
- source .venv/bin/activate
- pip install ../cryptography
- pip install -e .
- pip install -r dev-requirements.txt
- inv test
- """
- ],
- [
- downstreamName: 'aws-encryption-sdk',
- label: 'docker',
- imageName: 'pyca/cryptography-runner-ubuntu-rolling',
- script: """#!/bin/bash -xe
- git clone --depth=1 https://github.com/awslabs/aws-encryption-sdk-python
- cd aws-encryption-sdk-python
- virtualenv .venv
- source .venv/bin/activate
- pip install ../cryptography
- pip install -r test/requirements.txt
- pip install -e .
- pytest -m local -l
- """
- ],
- [
- downstreamName: 'certbot',
- label: 'docker',
- imageName: 'pyca/cryptography-runner-ubuntu-rolling',
- script: """#!/bin/bash -xe
- git clone --depth=1 https://github.com/certbot/certbot
- cd certbot
- virtualenv .venv
- source .venv/bin/activate
- pip install ../cryptography
- pip install pytest pytest-mock mock
- pip install -e acme
- pip install -e .
- pytest certbot/tests
- pytest acme
- """
- ],
- [
- downstreamName: 'certbot-josepy',
- label: 'docker',
- imageName: 'pyca/cryptography-runner-ubuntu-rolling',
- script: """#!/bin/bash -xe
- git clone --depth=1 https://github.com/certbot/josepy
- cd josepy
- virtualenv .venv
- source .venv/bin/activate
- pip install ../cryptography
- pip install -e .[tests]
- pytest src
- """
- ],
- [
- downstreamName: 'urllib3',
- label: 'docker',
- imageName: 'pyca/cryptography-runner-ubuntu-rolling',
- script: """#!/bin/bash -xe
- git clone --depth 1 https://github.com/shazow/urllib3
- cd urllib3
- virtualenv .venv
- source .venv/bin/activate
- pip install ../cryptography
- pip install -r ./dev-requirements.txt
- pip install -e .[socks]
- pytest test
- """
- ],
-]
-
def checkout_git(label) {
retry(3) {
def script = ""
@@ -423,26 +315,4 @@ builders["setup.py-test"] = {
}
}
-for (downstream in downstreams) {
- def downstreamName = downstream["downstreamName"]
- def imageName = downstream["imageName"]
- def label = downstream["label"]
- def script = downstream["script"]
- builders[downstreamName] = {
- node(label) {
- docker.image(imageName).inside {
- try {
- timeout(time: 30, unit: 'MINUTES') {
- checkout_git(label)
- sh script
- }
- } finally {
- deleteDir()
- }
- }
- }
- }
-}
-
parallel builders
-