aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 4 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index f79b0e25..7faac7c7 100644
--- a/setup.py
+++ b/setup.py
@@ -57,12 +57,11 @@ else:
requirements.append("cffi>=1.4.1")
setup_requirements.append("cffi>=1.4.1")
-# If you add a new dep here you probably need to add it in the tox.ini as well
test_requirements = [
"pytest",
"pretend",
"iso8601",
- "hypothesis",
+ "hypothesis>=1.11.4",
"pyasn1_modules",
]
@@ -308,6 +307,9 @@ setup(
install_requires=requirements,
tests_require=test_requirements,
+ extras_require={
+ "test": test_requirements,
+ },
# for cffi
zip_safe=False,