diff options
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 6 |
1 files changed, 5 insertions, 1 deletions
@@ -10,8 +10,11 @@ # implied. # See the License for the specific language governing permissions and # limitations under the License. +import sys + from setuptools import setup, find_packages + about = {} with open("cryptography/__about__.py") as fp: exec(fp.read(), about) @@ -27,6 +30,8 @@ setup_requires = [ CFFI_DEPENDENCY, ] +if sys.version_info[:2] < (3, 4): + install_requires += ["enum34"] setup( name=about["__title__"], @@ -49,7 +54,6 @@ setup( "Operating System :: POSIX :: BSD", "Operating System :: POSIX :: Linux", "Operating System :: Microsoft :: Windows", - #"Programming Language :: cffi", "Programming Language :: Python", "Programming Language :: Python :: 2", "Programming Language :: Python :: 2.6", |