aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index e1cc2394..1044c979 100644
--- a/setup.py
+++ b/setup.py
@@ -10,8 +10,11 @@
# implied.
# See the License for the specific language governing permissions and
# limitations under the License.
+import sys
+
from setuptools import setup, find_packages
+
about = {}
with open("cryptography/__about__.py") as fp:
exec(fp.read(), about)
@@ -27,6 +30,8 @@ setup_requires = [
CFFI_DEPENDENCY,
]
+if sys.version_info[:2] < (3, 4):
+ install_requires += ["enum34"]
setup(
name=about["__title__"],
@@ -49,7 +54,6 @@ setup(
"Operating System :: POSIX :: BSD",
"Operating System :: POSIX :: Linux",
"Operating System :: Microsoft :: Windows",
- #"Programming Language :: cffi",
"Programming Language :: Python",
"Programming Language :: Python :: 2",
"Programming Language :: Python :: 2.6",