aboutsummaryrefslogtreecommitdiffstats
path: root/vectors/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'vectors/setup.py')
-rw-r--r--vectors/setup.py21
1 files changed, 17 insertions, 4 deletions
diff --git a/vectors/setup.py b/vectors/setup.py
index 773fc456..13b27c7d 100644
--- a/vectors/setup.py
+++ b/vectors/setup.py
@@ -1,3 +1,18 @@
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+# implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+from __future__ import absolute_import, division, print_function
+
import os
from setuptools import setup, find_packages
@@ -5,8 +20,7 @@ from setuptools import setup, find_packages
base_dir = os.path.dirname(__file__)
about = {}
-with open(os.path.join(base_dir, "cryptography", "vectors",
- "__about__.py")) as f:
+with open(os.path.join(base_dir, "cryptography_vectors", "__about__.py")) as f:
exec(f.read(), about)
@@ -22,6 +36,5 @@ setup(
packages=find_packages(),
zip_safe=False,
- include_package_data=True,
- namespace_packages=['cryptography'],
+ include_package_data=True
)