aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Kriechbaumer <Kriechi@users.noreply.github.com>2018-03-24 11:41:21 +0100
committerGitHub <noreply@github.com>2018-03-24 11:41:21 +0100
commit2859ee2fa8c7f3311c069a40ada3975d31e8eccf (patch)
tree3988f38d67dd8fd45e94ec9ae8feff21d775d609
parentf34932c1717eac9840811f617f6af097c556d2e2 (diff)
parenteb297d82aafe3f3880e35676eba9361f4f459110 (diff)
downloadmitmproxy-2859ee2fa8c7f3311c069a40ada3975d31e8eccf.tar.gz
mitmproxy-2859ee2fa8c7f3311c069a40ada3975d31e8eccf.tar.bz2
mitmproxy-2859ee2fa8c7f3311c069a40ada3975d31e8eccf.zip
Merge pull request #3010 from Kriechi/bump-tornado
fix Tornado 5.0 event loop
-rw-r--r--setup.py2
-rw-r--r--test/mitmproxy/addons/test_onboarding.py4
2 files changed, 5 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 88d46ec5..d973249f 100644
--- a/setup.py
+++ b/setup.py
@@ -77,7 +77,7 @@ setup(
"pyperclip>=1.6.0, <1.7",
"ruamel.yaml>=0.13.2, <0.16",
"sortedcontainers>=1.5.4, <1.6",
- "tornado>=4.3, <4.6",
+ "tornado>=4.3,<5.1",
"urwid>=2.0.1,<2.1",
"wsproto>=0.11.0,<0.12.0",
],
diff --git a/test/mitmproxy/addons/test_onboarding.py b/test/mitmproxy/addons/test_onboarding.py
index 810ddef1..0d99b1ff 100644
--- a/test/mitmproxy/addons/test_onboarding.py
+++ b/test/mitmproxy/addons/test_onboarding.py
@@ -4,6 +4,10 @@ from mitmproxy.addons import onboarding
from mitmproxy.test import taddons
from .. import tservers
+import asyncio
+import tornado.platform.asyncio
+asyncio.set_event_loop_policy(tornado.platform.asyncio.AnyThreadEventLoopPolicy())
+
class TestApp(tservers.HTTPProxyTest):
def addons(self):