aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaximilian Hils <git@maximilianhils.com>2016-07-25 21:52:34 -0700
committerGitHub <noreply@github.com>2016-07-25 21:52:34 -0700
commitd97fe767dc7b8ea47f0e170c6f002c506f606d57 (patch)
tree231493860c039c96c9893e8b9647db2f8de82a9b
parent2c11cbeedb57548b64ddc4236c8014e71828f044 (diff)
downloadmitmproxy-d97fe767dc7b8ea47f0e170c6f002c506f606d57.tar.gz
mitmproxy-d97fe767dc7b8ea47f0e170c6f002c506f606d57.tar.bz2
mitmproxy-d97fe767dc7b8ea47f0e170c6f002c506f606d57.zip
update dependencies (#1435)
-rw-r--r--release/setup.py2
-rw-r--r--setup.py6
-rw-r--r--tox.ini2
3 files changed, 5 insertions, 5 deletions
diff --git a/release/setup.py b/release/setup.py
index 601654e5..b8eb6eec 100644
--- a/release/setup.py
+++ b/release/setup.py
@@ -6,7 +6,7 @@ setup(
py_modules=["rtool"],
install_requires=[
"click>=6.2, <7.0",
- "twine>=1.6.5, <1.7",
+ "twine>=1.6.5, <1.8",
"virtualenv>=14.0.5, <15.1",
"wheel>=0.29.0, <0.30",
"six>=1.10.0, <1.11",
diff --git a/setup.py b/setup.py
index e76fed2b..23eb3b26 100644
--- a/setup.py
+++ b/setup.py
@@ -80,7 +80,7 @@ setup(
"pyperclip>=1.5.22, <1.6",
"requests>=2.9.1, <2.11",
"six>=1.10, <1.11",
- "tornado>=4.3, <4.4",
+ "tornado>=4.3, <4.5",
"urwid>=1.3.1, <1.4",
"watchdog>=0.8.3, <0.9",
],
@@ -116,9 +116,9 @@ setup(
# "pyamf>=0.8.0, <0.9",
],
'examples': [
- "beautifulsoup4>=4.4.1, <4.5",
+ "beautifulsoup4>=4.4.1, <4.6",
"harparser>=0.2, <0.3",
- "pytz>=2015.07.0, <=2016.4",
+ "pytz>=2015.07.0, <=2016.6.1",
]
}
)
diff --git a/tox.ini b/tox.ini
index 9da23a2e..ff0e41c2 100644
--- a/tox.ini
+++ b/tox.ini
@@ -17,5 +17,5 @@ changedir = docs
commands = sphinx-build -W -b html -d {envtmpdir}/doctrees . {envtmpdir}/html
[testenv:lint]
-deps = flake8>=2.6.2, <3
+deps = flake8>=2.6.2, <3.1
commands = flake8 --jobs 8 --count mitmproxy netlib pathod examples test