aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaximilian Hils <git@maximilianhils.com>2016-12-11 18:15:00 +0100
committerGitHub <noreply@github.com>2016-12-11 18:15:00 +0100
commitf16aab963e20a6c2fa2f63d7841b71f6d068783f (patch)
tree9fc5bd40b792f8ec547845380c5510bf8193b9cb
parentb62b92eabe9d6ab1c3ecea87a18740eef730f157 (diff)
parent8f042254506900aa97c66eb960d6699297981b8a (diff)
downloadmitmproxy-f16aab963e20a6c2fa2f63d7841b71f6d068783f.tar.gz
mitmproxy-f16aab963e20a6c2fa2f63d7841b71f6d068783f.tar.bz2
mitmproxy-f16aab963e20a6c2fa2f63d7841b71f6d068783f.zip
Merge pull request #1841 from mitmproxy/fix-docs-tests
pin docutils version to fix docs tests
-rw-r--r--docs/install.rst4
-rw-r--r--setup.py1
2 files changed, 5 insertions, 0 deletions
diff --git a/docs/install.rst b/docs/install.rst
index b6160a9c..1fe09aca 100644
--- a/docs/install.rst
+++ b/docs/install.rst
@@ -61,6 +61,7 @@ Installation On macOS
You can use Homebrew to install everything:
.. code:: bash
+
brew install mitmproxy
Or you can download the pre-built binary packages from `mitmproxy.org`_.
@@ -86,17 +87,20 @@ If you already have an older version of Python 3.5 installed, make sure to insta
(pip is included in Python by default). If pip aborts with an error, make sure you are using the current version of pip.
.. code:: powershell
+
python -m pip install --upgrade pip
Next, add Python and the Python Scripts directory to your **PATH** variable.
You can do this easily by running the following in powershell:
.. code:: powershell
+
[Environment]::SetEnvironmentVariable("Path", "$env:Path;C:\Python27;C:\Python27\Scripts", "User")
Now, you can install mitmproxy by running
.. code:: powershell
+
pip install mitmproxy
Once the installation is complete, you can run :ref:`mitmdump` from a command prompt.
diff --git a/setup.py b/setup.py
index f02132d0..0b0423ec 100644
--- a/setup.py
+++ b/setup.py
@@ -106,6 +106,7 @@ setup(
"sphinx>=1.3.5, <1.6",
"sphinx-autobuild>=0.5.2, <0.7",
"sphinxcontrib-documentedlist>=0.4.0, <0.5",
+ "docutils==0.12", # temporary pin, https://github.com/chintal/sphinxcontrib-documentedlist/pull/3
"sphinx_rtd_theme>=0.1.9, <0.2",
],
'contentviews': [