aboutsummaryrefslogtreecommitdiffstats
path: root/examples/pathod/test_setup.py
diff options
context:
space:
mode:
authorAldo Cortesi <aldo@nullcube.com>2016-02-18 10:15:59 +1300
committerAldo Cortesi <aldo@nullcube.com>2016-02-18 10:15:59 +1300
commit36e070ee25ab09ecb9b38dd7f2c5cd8de0073c10 (patch)
tree3eeb285b22b533dcd67ad3680f422882be7e30fe /examples/pathod/test_setup.py
parent2e7b29ce20c3eb7eaa0cddf6e1188c80e7c1d1b1 (diff)
downloadmitmproxy-36e070ee25ab09ecb9b38dd7f2c5cd8de0073c10.tar.gz
mitmproxy-36e070ee25ab09ecb9b38dd7f2c5cd8de0073c10.tar.bz2
mitmproxy-36e070ee25ab09ecb9b38dd7f2c5cd8de0073c10.zip
Pull bin to the top, move pathod examples to examples dir
Diffstat (limited to 'examples/pathod/test_setup.py')
-rw-r--r--examples/pathod/test_setup.py31
1 files changed, 31 insertions, 0 deletions
diff --git a/examples/pathod/test_setup.py b/examples/pathod/test_setup.py
new file mode 100644
index 00000000..5dbc456d
--- /dev/null
+++ b/examples/pathod/test_setup.py
@@ -0,0 +1,31 @@
+import requests
+from pathod import test
+
+
+class Test:
+
+ """
+ Testing the requests module with
+ a pathod instance started for
+ each test.
+ """
+
+ def setup(self):
+ self.d = test.Daemon()
+
+ def teardown(self):
+ self.d.shutdown()
+
+ def test_simple(self):
+ # Get a URL for a pathod spec
+ url = self.d.p("200:b@100")
+ # ... and request it
+ r = requests.put(url)
+
+ # Check the returned data
+ assert r.status_code == 200
+ assert len(r.content) == 100
+
+ # Check pathod's internal log
+ log = self.d.last_log()["request"]
+ assert log["method"] == "PUT"