aboutsummaryrefslogtreecommitdiffstats
path: root/pathod/examples
diff options
context:
space:
mode:
authorMaximilian Hils <git@maximilianhils.com>2016-02-15 14:58:49 +0100
committerMaximilian Hils <git@maximilianhils.com>2016-02-15 14:58:49 +0100
commit175ce43a30559115c08e41e5d87519e957ff96f6 (patch)
tree9231c6396d15b70601492458b33f44bfe579233b /pathod/examples
parent43c3e164ecf13b2d0909f748c2c61f39e197659e (diff)
parente8598f5f7a613d7d27130de970b4c0045b3ee0d1 (diff)
downloadmitmproxy-175ce43a30559115c08e41e5d87519e957ff96f6.tar.gz
mitmproxy-175ce43a30559115c08e41e5d87519e957ff96f6.tar.bz2
mitmproxy-175ce43a30559115c08e41e5d87519e957ff96f6.zip
add pathod
Diffstat (limited to 'pathod/examples')
-rw-r--r--pathod/examples/libpathod_pathoc.py7
-rw-r--r--pathod/examples/test_context.py23
-rw-r--r--pathod/examples/test_setup.py31
-rw-r--r--pathod/examples/test_setupall.py39
4 files changed, 100 insertions, 0 deletions
diff --git a/pathod/examples/libpathod_pathoc.py b/pathod/examples/libpathod_pathoc.py
new file mode 100644
index 00000000..cf94151b
--- /dev/null
+++ b/pathod/examples/libpathod_pathoc.py
@@ -0,0 +1,7 @@
+#!/usr/bin/env python
+from libpathod import pathoc
+
+p = pathoc.Pathoc(("google.com", 80))
+p.connect()
+print p.request("get:/")
+print p.request("get:/foo")
diff --git a/pathod/examples/test_context.py b/pathod/examples/test_context.py
new file mode 100644
index 00000000..7c0386c1
--- /dev/null
+++ b/pathod/examples/test_context.py
@@ -0,0 +1,23 @@
+import requests
+from libpathod import test
+
+
+def test_simple():
+ """
+ Testing the requests module with
+ a pathod context manager.
+ """
+ # Start pathod in a separate thread
+ with test.Daemon() as d:
+ # Get a URL for a pathod spec
+ url = d.p("200:b@100")
+ # ... and request it
+ r = requests.put(url)
+
+ # Check the returned data
+ assert r.status_code == 200
+ assert len(r.content) == 100
+
+ # Check pathod's internal log
+ log = d.last_log()["request"]
+ assert log["method"] == "PUT"
diff --git a/pathod/examples/test_setup.py b/pathod/examples/test_setup.py
new file mode 100644
index 00000000..6085c98a
--- /dev/null
+++ b/pathod/examples/test_setup.py
@@ -0,0 +1,31 @@
+import requests
+from libpathod import test
+
+
+class Test:
+
+ """
+ Testing the requests module with
+ a pathod instance started for
+ each test.
+ """
+
+ def setup(self):
+ self.d = test.Daemon()
+
+ def teardown(self):
+ self.d.shutdown()
+
+ def test_simple(self):
+ # Get a URL for a pathod spec
+ url = self.d.p("200:b@100")
+ # ... and request it
+ r = requests.put(url)
+
+ # Check the returned data
+ assert r.status_code == 200
+ assert len(r.content) == 100
+
+ # Check pathod's internal log
+ log = self.d.last_log()["request"]
+ assert log["method"] == "PUT"
diff --git a/pathod/examples/test_setupall.py b/pathod/examples/test_setupall.py
new file mode 100644
index 00000000..f0ba5844
--- /dev/null
+++ b/pathod/examples/test_setupall.py
@@ -0,0 +1,39 @@
+import requests
+from libpathod import test
+
+
+class Test:
+
+ """
+ Testing the requests module with
+ a single pathod instance started
+ for the test suite.
+ """
+ @classmethod
+ def setup_class(cls):
+ cls.d = test.Daemon()
+
+ @classmethod
+ def teardown_class(cls):
+ cls.d.shutdown()
+
+ def setup(self):
+ # Clear the pathod logs between tests
+ self.d.clear_log()
+
+ def test_simple(self):
+ # Get a URL for a pathod spec
+ url = self.d.p("200:b@100")
+ # ... and request it
+ r = requests.put(url)
+
+ # Check the returned data
+ assert r.status_code == 200
+ assert len(r.content) == 100
+
+ # Check pathod's internal log
+ log = self.d.last_log()["request"]
+ assert log["method"] == "PUT"
+
+ def test_two(self):
+ assert not self.d.log()