aboutsummaryrefslogtreecommitdiffstats
path: root/pathod/language/http.py
diff options
context:
space:
mode:
authorMaximilian Hils <git@maximilianhils.com>2017-05-27 01:55:43 +0200
committerGitHub <noreply@github.com>2017-05-27 01:55:43 +0200
commite7f7a608c6dda7cc22d2eda1129da99fd2830767 (patch)
tree4c6879f8dc964010750617c47eb7ee927c891b6b /pathod/language/http.py
parentef1c36194e0cb3ac82304eb95fb323d71ec5ebab (diff)
parente7990e0983344179e49a46f160e1482a0a0f6aa7 (diff)
downloadmitmproxy-e7f7a608c6dda7cc22d2eda1129da99fd2830767.tar.gz
mitmproxy-e7f7a608c6dda7cc22d2eda1129da99fd2830767.tar.bz2
mitmproxy-e7f7a608c6dda7cc22d2eda1129da99fd2830767.zip
Merge pull request #2358 from mhils/make-mypy-great-again
Fix mypy annotations, update mypy
Diffstat (limited to 'pathod/language/http.py')
-rw-r--r--pathod/language/http.py6
1 files changed, 4 insertions, 2 deletions
diff --git a/pathod/language/http.py b/pathod/language/http.py
index 5cd717a9..5a962145 100644
--- a/pathod/language/http.py
+++ b/pathod/language/http.py
@@ -54,7 +54,9 @@ class Method(base.OptionsOrValue):
class _HeaderMixin:
- unique_name = None # type: ignore
+ @property
+ def unique_name(self):
+ return None
def format_header(self, key, value):
return [key, b": ", value, b"\r\n"]
@@ -251,7 +253,7 @@ class Response(_HTTPMessage):
return ":".join([i.spec() for i in self.tokens])
-class NestedResponse(base.NestedMessage):
+class NestedResponse(message.NestedMessage):
preamble = "s"
nest_type = Response