aboutsummaryrefslogtreecommitdiffstats
path: root/pathod/language/http2.py
diff options
context:
space:
mode:
authorMaximilian Hils <git@maximilianhils.com>2017-05-27 01:55:43 +0200
committerGitHub <noreply@github.com>2017-05-27 01:55:43 +0200
commite7f7a608c6dda7cc22d2eda1129da99fd2830767 (patch)
tree4c6879f8dc964010750617c47eb7ee927c891b6b /pathod/language/http2.py
parentef1c36194e0cb3ac82304eb95fb323d71ec5ebab (diff)
parente7990e0983344179e49a46f160e1482a0a0f6aa7 (diff)
downloadmitmproxy-e7f7a608c6dda7cc22d2eda1129da99fd2830767.tar.gz
mitmproxy-e7f7a608c6dda7cc22d2eda1129da99fd2830767.tar.bz2
mitmproxy-e7f7a608c6dda7cc22d2eda1129da99fd2830767.zip
Merge pull request #2358 from mhils/make-mypy-great-again
Fix mypy annotations, update mypy
Diffstat (limited to 'pathod/language/http2.py')
-rw-r--r--pathod/language/http2.py10
1 files changed, 6 insertions, 4 deletions
diff --git a/pathod/language/http2.py b/pathod/language/http2.py
index 47d6e370..5b27d5bf 100644
--- a/pathod/language/http2.py
+++ b/pathod/language/http2.py
@@ -1,9 +1,9 @@
import pyparsing as pp
+
from mitmproxy.net import http
from mitmproxy.net.http import user_agents, Headers
from . import base, message
-
"""
Normal HTTP requests:
<method>:<path>:<header>:<body>
@@ -41,7 +41,9 @@ def get_header(val, headers):
class _HeaderMixin:
- unique_name = None # type: ignore
+ @property
+ def unique_name(self):
+ return None
def values(self, settings):
return (
@@ -146,7 +148,7 @@ class Times(base.Integer):
class Response(_HTTP2Message):
- unique_name = None # type: ignore
+ unique_name = None
comps = (
Header,
Body,
@@ -203,7 +205,7 @@ class Response(_HTTP2Message):
return ":".join([i.spec() for i in self.tokens])
-class NestedResponse(base.NestedMessage):
+class NestedResponse(message.NestedMessage):
preamble = "s"
nest_type = Response