aboutsummaryrefslogtreecommitdiffstats
path: root/release/pyinstaller-mitmdump.spec
diff options
context:
space:
mode:
authorAldo Cortesi <aldo@nullcube.com>2013-05-15 11:25:25 +1200
committerAldo Cortesi <aldo@nullcube.com>2013-05-15 11:25:25 +1200
commit9e94fdc6db83bc2d11b6a9cd1df5222827df3ce8 (patch)
tree564fff39331e920e626696d30584e246058479eb /release/pyinstaller-mitmdump.spec
parent52b56e23b265006c29e73e6af37713331af7f5ac (diff)
downloadmitmproxy-9e94fdc6db83bc2d11b6a9cd1df5222827df3ce8.tar.gz
mitmproxy-9e94fdc6db83bc2d11b6a9cd1df5222827df3ce8.tar.bz2
mitmproxy-9e94fdc6db83bc2d11b6a9cd1df5222827df3ce8.zip
Make ready for pyinstaller.
Diffstat (limited to 'release/pyinstaller-mitmdump.spec')
-rw-r--r--release/pyinstaller-mitmdump.spec20
1 files changed, 20 insertions, 0 deletions
diff --git a/release/pyinstaller-mitmdump.spec b/release/pyinstaller-mitmdump.spec
new file mode 100644
index 00000000..a1a9b937
--- /dev/null
+++ b/release/pyinstaller-mitmdump.spec
@@ -0,0 +1,20 @@
+# -*- mode: python -*-
+
+# Copy into the pyinstaller directory
+# ./pyinstaller.py --clean -F ./pyinstaller-mitmdump.spec
+
+a = Analysis(['/Users/aldo/git/public/mitmproxy/mitmdump'],
+ hiddenimports=["pyamf"],
+ hookspath=None,
+ runtime_hooks=None)
+pyz = PYZ(a.pure)
+exe = EXE(pyz,
+ a.scripts,
+ a.binaries,
+ a.zipfiles,
+ a.datas,
+ name='mitmdump',
+ debug=False,
+ strip=None,
+ upx=True,
+ console=True )