aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Kriechbaumer <Kriechi@users.noreply.github.com>2016-02-04 10:51:18 +0100
committerThomas Kriechbaumer <Kriechi@users.noreply.github.com>2016-02-04 10:51:18 +0100
commit023026e032f7f78a53a598eb7bd130d1b14930d2 (patch)
tree01982db6659f75f2bfe737a81b82022550e48e28 /setup.py
parentae4a1dd6dec9d95e450837db8937e3fb7604c121 (diff)
parent98f54d21b6156ceaa8450072be9f53dfde137248 (diff)
downloadmitmproxy-023026e032f7f78a53a598eb7bd130d1b14930d2.tar.gz
mitmproxy-023026e032f7f78a53a598eb7bd130d1b14930d2.tar.bz2
mitmproxy-023026e032f7f78a53a598eb7bd130d1b14930d2.zip
Merge pull request #883 from mitmproxy/hyper-h2
HTTP/2: Implementation using hyper-h2
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 29ac4753..f70eda46 100644
--- a/setup.py
+++ b/setup.py
@@ -17,6 +17,7 @@ with open(os.path.join(here, 'README.rst'), encoding='utf-8') as f:
# This will break `pip install` on systems with old setuptools versions.
deps = {
"netlib>=%s, <%s" % (version.MINORVERSION, version.NEXT_MINORVERSION),
+ "h2>=2.1.0, <3.0",
"tornado>=4.3.0, <4.4",
"configargparse>=0.10.0, <0.11",
"pyperclip>=1.5.22, <1.6",
@@ -45,6 +46,7 @@ dev_deps = {
"pytest>=2.8.0",
"pytest-xdist>=1.13.1",
"pytest-cov>=2.1.0",
+ "pytest-timeout>=1.0.0",
"coveralls>=0.4.1",
"pathod>=%s, <%s" % (version.MINORVERSION, version.NEXT_MINORVERSION),
"sphinx>=1.3.1",