diff options
author | Jim Shaver <dcypherd@gmail.com> | 2015-06-23 21:48:05 -0500 |
---|---|---|
committer | Jim Shaver <dcypherd@gmail.com> | 2015-06-23 21:48:05 -0500 |
commit | 080e4534253338c94e6d8c86cb3679ff15410f85 (patch) | |
tree | 6322fb822332b4135f0ff14de8c2d7137016f734 /setup.py | |
parent | db5c0b210b0133d7cd58124c727dbc24480e2568 (diff) | |
parent | 074d8d7c7463cdb1f0a90e165a4b3ada3554b4c2 (diff) | |
download | mitmproxy-080e4534253338c94e6d8c86cb3679ff15410f85.tar.gz mitmproxy-080e4534253338c94e6d8c86cb3679ff15410f85.tar.bz2 mitmproxy-080e4534253338c94e6d8c86cb3679ff15410f85.zip |
Merge branch 'master' into hardfailvenv
Conflicts:
dev
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 28 |
1 files changed, 12 insertions, 16 deletions
@@ -18,10 +18,12 @@ if os.name != "nt": deps = { "netlib>=%s, <%s" % (version.MINORVERSION, version.NEXT_MINORVERSION), "pyasn1>0.1.2", - "pyOpenSSL>=0.14", "tornado>=4.0.2", "configargparse>=0.9.3", - "pyperclip>=1.5.8" + "pyperclip>=1.5.8", + "blinker>=1.3", + "pyparsing>=1.5.2", + "html2text>=2015.4.14" } script_deps = { "mitmproxy": { @@ -66,13 +68,11 @@ setup( "Topic :: Internet", "Topic :: Internet :: WWW/HTTP", "Topic :: Internet :: Proxy Servers", - "Topic :: Software Development :: Testing" - ], + "Topic :: Software Development :: Testing"], packages=find_packages(), include_package_data=True, entry_points={ - 'console_scripts': console_scripts - }, + 'console_scripts': console_scripts}, install_requires=list(deps), extras_require={ 'dev': [ @@ -80,19 +80,15 @@ setup( "nose>=1.3.0", "nose-cov>=1.6", "coveralls>=0.4.1", - "pathod>=%s, <%s" % ( - version.MINORVERSION, version.NEXT_MINORVERSION - ) - ], + "pathod>=%s, <%s" % + (version.MINORVERSION, + version.NEXT_MINORVERSION), + "countershape"], 'contentviews': [ "pyamf>=0.6.1", "protobuf>=2.5.0", - "cssutils>=1.0" - ], + "cssutils>=1.0"], 'examples': [ "pytz", "harparser", - "beautifulsoup4" - ] - } -) + "beautifulsoup4"]}) |